Bugs

Lag on Commands in 1.8.5p2?

Submitted by thekou on Mon, 2012-08-06 19:01

I've just updated and then installed a fresh copy of 1.8.5p2 to test, and I'm finding that out of the box, all commands (except $-commands stored on local objects) and function-calls (and just plain ol stuff like 'say' and 'pose') are resulting in about 0.5secs of lag before the output shows up. Not happening on the same host (mudhosting) with 1.8.4p7 or p8.

Very odd, and a bit of a mystery. I'm looking at other games that are on 1.8.5+ that are running with none of this random spot-lag. I just can't figure out why it's happening.

Problem with "connect.txt"

Submitted by geradon on Thu, 2011-09-08 18:05

Hello everybody, I just installed PennMUSH on my dedicated server and it works almost perfectly.

Almost ; I'm french speaking, and I'm using the french .mo file. My MUSH client is set to Latin1, my LANG on the server is set to FR_fr, and almost everything runs fine with accents.

My only issue so far is that, while EVERY .txt in /game/txt/ displays accents, "connect.txt" doesn't.

Possible bug in PennMush 1.8.4p1

Submitted by Argon on Sun, 2010-11-14 18:48

Okay, I know this is not the right place to report a bug. But the fact is, with my rather poor eyesight, the catcha that's part of creating a google account defeated me. Which makes reporting this issue on the official bug tracking system kind of impossible for me.

Using PennMush 1.8.4p1 hosted on Dune.

These give a #-1 Invalid Flag result when the target is a player ->

think orflags(#3,p) - and - think orlflags(#3,puppet)

Puppet (p) appears in @flag/list.

orflags() and orlflags() work correctly when the target is a thing.

How do we submit bugs?

Submitted by Lolkje on Thu, 2009-08-20 16:28

I tried to submit a bug at dev.pennmush.org, and the site is saying "Warning: Can't synchronize with the repository (/svn/pennmush does not appear to be a Subversion repository.). Look in the Trac log for more information." Trying to create a ticket or register a Trac account results in internal errors.

I also tried sending an e-mail to pennmush-bugs@pennmush.org, but it bounced back as "The email account that you tried to reach does not exist."

Auto disconnect when idle? Flood?

Submitted by annP on Sun, 2009-04-19 22:03

Players on my pennnmush game have noticed a bug that's baffling me. They can chat and roleplay like normal, but if they're silent for more than a few minutes and then suddenly pose a reply in room or chat, their screen freezes and then the MUSH kicks them off about 30 secs later. As long as they keep up a constant stream of chatter, no one gets kicked. Silence and then pose and everyone gets kicked. Ideas? What kind of problem could this be? Thanks :)